Mostly Harmless

Difference between revisions of "Legacy:Operators/Discuss"

From Unreal Wiki, The Unreal Engine Documentation Site
Jump to: navigation, search
m
 
Line 43: Line 43:
 
|...
 
|...
 
|...  
 
|...  
 +
|}
 +
 +
'''Mychaeel:'''  Yeah, more or less.  I'd keep the first-level grouping by "string," "number" (int, byte, float), "vector," "rotator."  I think the columns I used for the boolean operator table work best; rows should be sorted by precedence (highest first):
 +
 +
===Numeric Operators ===
 +
 +
{|
 +
 +
|-
 +
|'''Operation'''
 +
|'''Operator'''
 +
|'''Applies to'''
 +
|'''Precedence'''
 +
|'''Description'''
 +
|-
 +
|Addition
 +
| style="text-align: center" |<code>+</code>
 +
|''all''
 +
| style="text-align: right" |20
 +
|Calculates the sum of both operands
 +
|-
 +
|Increment
 +
| style="text-align: center" |<code>++</code>
 +
|Variables
 +
| style="text-align: right" |Pre-/Postoperator
 +
|Increments the variable by 1
 
|}
 
|}

Latest revision as of 08:20, 20 May 2002

Mychaeel, on the Wiki forum: Specifically on that Operators page I firmly believe that it was not a good idea to give each and every operator a heading and a section of its own; menu or not, it's definitely not very readable that way. That's why I started putting the operators in tables (see the "Boolean Operators" section).

Tarquin: I have a suggestion, which may reduce the length & complexity of this page. IMHO it might be more logical, but as I'm not really a coder, more of a hybrid docer / mapper, maybe a moccer... anyway:

Group by operator first, then by variable type. Booleans are the exception, I think the boolean table should stay. But beyond that, how about:

== Equality[edit]

Applies to: String, Boolean, Int, Byte, Float, Vector ... etc

+ Addition[edit]

Applies to: Int, Byte, Float, Vector ... etc

Mychaeel: Since there are way more operators than data types that scheme just needlessly bloats the page – and it doesn't reflect how I'd personally start looking for a certain operator either. Use headings instead to group by data type those operators apply to – "Boolean Operators," "String Operators" ($, @), "Numeric Operators" (+, -, *, /), and so on.

Tarquin: I guess that's more what I meant – "numeric operators" for +, - etc, since it's bit bloaty to repeat what + does for byte / int / float.

Wormbo: How about tables like this one:

Numeric Operators[edit]

Operator Meaning Applies to Priority
++ Increment byte, int Pre-/Postoperator
+ Add int, float 20
... ... ... ...

Mychaeel: Yeah, more or less. I'd keep the first-level grouping by "string," "number" (int, byte, float), "vector," "rotator." I think the columns I used for the boolean operator table work best; rows should be sorted by precedence (highest first):

Numeric Operators[edit]

Operation Operator Applies to Precedence Description
Addition + all 20 Calculates the sum of both operands
Increment ++ Variables Pre-/Postoperator Increments the variable by 1