I'm a doctor, not a mechanic

Legacy:Rhinoceros

From Unreal Wiki, The Unreal Engine Documentation Site
Revision as of 18:48, 24 December 2005 by Bob The Beheader (Talk) (comment)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Rhinoceros is a Modeling Application. Rhinoceros supports NURBS and polygon mesh modeling. It is widely recognized for its strengths in organic modeling. Take advantage of the variety of surface and solid deformation commands, as well as the very useful commands for creating surfaces through curves.

Set the Grid[edit]

Rhino's grid can be set to any unit of measurement. To match Unreal Units, set all grid options to powers of 2 just like Unreal. For example:

  • Grid Extents (maximum viewable grid) = 1024;
  • Major Grid Lines = 32
  • Minor Grid Lines = 8

To make Rhino modeling easier for Unreal, set the grid options and then save the file as a template.

Modeling[edit]

Model entirely in NURBS, then convert to polygon mesh.

  • Use Mesh From NURBS Object on the toolbar. The polygon conversion bar is used to detemine the mesh density.
  • ReduceMesh (Tools -> Polygon Mesh -> ReduceMesh). Make certain your polycount is as close to a perfect exponent of 2 as possible.
  • Each face on a mesh has a direction that either points outward or inward. They can also be 2-sided. Make sure the mesh face direction is pointing outward by using the analyze -> direction (command name = "dir") to view and change its direction.

Importing into UnrealEd[edit]

These are the sequential steps for converting Rhino models to any types of polygon brush, mesh or static mesh. Static meshes are for UT2003 or later.

BSP[edit]

  1. File -> Export Selected as an AutoCAD DXF
  2. Import into Ued Brush -> Import.

Mesh[edit]

  1. File -> Export Selected as an AutoCAD DXF
  2. Import into Ued Brush -> Import.
  3. Add brush. Texture.
  4. Brush -> Polygons -> To brush
  5. Brush -> Export
  6. Use MeshMaker to convert your BSP brush to a mesh.

Static Mesh[edit]

  1. File -> Export Selected as an AutoCAD DXF
  2. Import to MilkShape using File -> Import -> AutoCAD DXF
  3. Export using File -> Export -> LightWave LWO, making sure to use the bottom-most LWO option. In UnrealEd 3's static mesh browser use File -> Import.
  4. Fill in your Package\Group\Name. myLevel is recommended for your package.

Discussion[edit]

Foxpaw: I had a couple of questions about using Rhino to make static meshes:

  • Above it says you should use reducemesh to make sure your polycount is in base 8 - does that mean to ensure that it's a multiple of 8? (I assume that it does)
  • When I import my meshes into UEd, the faces are always inverted. Is there a way to set Rhino to invert the faces when I save to DXF so that they'll be the right way around when I import to UEd?
  • Whats a good grid scale to use with Rhino? IE, if I want the grid points in Rhino to be nice, round numbers of UUs?
  • Is there any way (plug-in or otherwise) for me to get a little more control over textures? The only texturing ability I can find is setting a texture, no ability to UV map or anything like that.

Sobiwan:

  • The help file for v3 says nothing about base8, so I suspect it was from an earlier version. I tried ReduceMesh and found there was no difference from using it compared to converting from nurbs to mesh (command = mesh). I kept the text so someone could verify my findings.
  • Use analyze -> direction (command = dir) to change the face normal direction.
  • Grid scale is custom. See grid text above.
  • v3 automatically does UV mapping from NURBS to polygon meshes. I dont recall if it was available in v1, but it was in v2 since the v3 whatsnew file doesnt list UV mapping.

GRAF1K: The reason your faces are inverted is a result of not keeping your polycount in base 8. A polycount of 513 rather than 512 will most likely wreak all face-normal havoc upon your mesh.

Foxpaw: What exactly does that mean? I know what Base 8 is, but any number can be represented in Base 8, so I'm a bit unclear. Do you mean that the polycount has to be a multiple of 8? That is has to be an integrally exponentiated from 8? As for the automatic UV mapping.. that's the problem. Rhino decides how and where to line up the textures, and I disagree with it's assessment of which parts of the skin belong where. :P Is there anyway to override that?

GRAF1K: 8, 16, 32, etc. usually work best. However, 384-type numbers (because 256 + 128 = 384) works most of the time as well. A little experimentation is due. As for UV-mapping, I'm lost myself. :P I usually use Milkshape's Window -> Texture Coordinate Editor. Not very satisfactory though.

Kirk: I've played around with Rhino and making static meshes today, and if you have 3DS Max as well... they team up really well. You can just make yer NURBS in Rhino, easily and awesome, and then export it using the IGES file format. Max can import that, and it supports NURBS! So then you'll have Rhino-made NURBS in Max, which you can then UV Map is neccesary, or play with the Surface settings of the NURBS object instead. You can then use the automatic NURBS tesselation to generate a balanced number of polygons (doesn't have to be base 8 or anything), and then you just apply texture. You don't even have to collapse the tree or convert to Editable Mesh when exporting, from what I've noticed.

Bob_The_Beheader: I made this friggin' awesome spaceship with Rhino. Unfortunatly my computer crashed one day... :( But It was so easy to make with Rhino, and took less time then it would have with other modeling apps. I really recommend this. One question. Does it have any support for texturing models? ... Milkshape is annoying as hell for texturing. I think one can sort of import non-character models into UPaint...but...

Foxpaw: You can texture a model in Rhino by editing it's "object properties." However, there is no facility to control which parts of the texture appear on which parts of the model.

I have heard that the "Dir" command can be used (in the Rhino console) to affect where the texture is centered and stuff, but I haven't tried it. I've also heard that a model exported into another piece of software, textured, and then imported into Rhino will retain it's UV mapping. I haven't tried that either.

The reason that Rhino has such limited texture mapping capability is that it's intended commercial application is for CAD and machining, rather than building models for display in a 3D world. Having said that I do find it to be superb for creating 3D meshes.

Graphik: Personally, I tried Maya and never looked back. Now Rhino seems like nothing more than a necessary evil – a stepping-stone on my path to Maya.

Bob_The_Beheader: O.k. Should have read what other people said before I asked about textureing...stupid of me... I find Maya to be a necessary evil, 'cept for animation. To each his/her own I guess.